So, a while ago I was on my Windows 7 PC being very productive (listening to SEGA music) when things went horribly awry. Basically every program started running x100 slower than normal.

The web browsers are the hardest-hit, Chrome and IE crash on startup. Most other programs are just really slow to run now. Occasionally, certain files are impossible to send to the recycle bin or modify unless you reboot. Here's some stuff I tried...

Ran Windows Defender -- No effect
System restore + reboot -- No effect
Linux-based malscan of volume -- No viruses
Uninstall + Reinstall browsers -- No effect
Updated out-of-date drivers -- No effect
Win 7 repair disc -- Failed, repair process hangs at 89%
TestRam86+ -- No RAM error detected
Chkdsk C: -- No improvement
New SATA cable -- No improvement
Unplugged SATA DVD drive -- No improvement

...I checked the Windows event log for oddities and found tons of "atapi error 11" related errors mostly concentrated around the start of the problem...

The driver detected a controller error on \Device\Ide\IdePort2

I've had this PC setup for almost a year, but actually haven't used it as much as I might have because it's always been a bit flaky. For a while Windows 7 would boot into a blank screen maybe 1/3rd of the time. Then I did a Win 7 repair, which seemed to fix things. Now there's this new mystery. I'm suspecting some kind of problem with either the particular hard drive (Toshiba DT01ACA200), the motherboard (Gigabyte 990FXA-UD3), or the combination of them both.
That sounds like a typical harddrive failure. Back up any and all important data asap. Start with the can not lose and work your way down Hopefully the drive lasts long enough to make the backup. And get a new hdd and start a new :/
Sadly, this does indeed present the symptoms of a rapidly-failing hard drive. I recommend you get everything you can off of the disk while you can and replace it. Perhaps it's time to consider an SSD for your primary drive? Smile
I agree that this looks like a disk problem. It might not be a failing disk so much as just a bad connection though, so the first thing to try would be just reseating the connections to the hard drive. If that doesn't help, then try another disk.
New HDD for sure!
Aw man, that's crazy! I got these drives last October.
[ Update / edit ]

KermMartian wrote:
Sadly, this does indeed present the symptoms of a rapidly-failing hard drive. I recommend you get everything you can off of the disk while you can and replace it. Perhaps it's time to consider an SSD for your primary drive? Smile

Yeah, I'll look into this option. Pretty much everything was backed up earlier this summer. I'll try out one last driver reinstall and then a BIOS update. After that, I'll probably switch to a different HDD.
Looks like the plot thickens. I plugged in an older drive with Win XP + Ubuntu + openSUSE installed and that starting running slow too. It took Ubuntu around 5 mins to render the login screen.

Then I rebooted and tried openSUSE, which was still set to boot in verbose mode. This is what I saw:

device descriptor read/64 error 110

After some Googling, it looks like this is telling me some USB devices were unable to enumerate due to power being exceeded (or not enough available, there were a few different interpretations of this error). I unplugged the USB headphones and the USB wifi mini-dongle, which seems to fix the issue--at least so far.
That is a very strange symptom indeed. Are things continuing to run properly with everything USB except your keyboard and mouse unplugged? Does it matter which set of USB ports you use?
4-month bump! I decided the revisit this one for the tail end of winter vacation.

Right now the USB ports are empty except for a keyboard and mouse. So far, this is looking like a mix of software and possible hardware problems. Luckily, I made some huge progress today.

So I booted up the Windows 7-only disk to try and get it running again. Just to recap, this is the disk image that was only semi-functional. It ran decently when it was new, but certain programs (particularly, all web browsers) became unacceptable slow and crash-prone. To condense things, here are some fixes I tried:

1. Downloaded drivers directly from Gigabyte...
__ a. Audio chip driver
__ b. AMD chipset driver
__ c. LAN driver
__ d. AHCI/RAID driver
__ e. SATA/RAID chipset driver
__ f. USB 3.0 driver
2. Ran Realtek Ethernet diagnostic utility. [PASSED]
3. Enabled IOMMU via the BIOS settings.
4. Did lots of Windows updates + reboots
5. Updated Flash just in case

This fixed a few nagging audio problems and Device Manager notifications, but all browsers (IE11, Chrome, Opera) were still way slower than expected. Chrome was completely non-functional.

At that point, I opened up the Task Manager and noticed one service: dllhost.exe was using nearly 100% CPU utilization at all times. After some more googling, I found one user on techsupportforum who had the same problem and solved it by changing the icon/thumbnail settings for windows explorer. I followed those directions (which entailed checking and un-checking just 2 settings) and rebooted. And bam! The browsers ran perfectly normally.

Afterward I had some malware problems after downloading Teamviewer. I have no idea of how they were downloaded or if they were bundled with the otherwise-legit Teamviewer software.

Namely, 3 browser hijackers suddenly appeared and altered my homepage settings and generated some highly obnoxious pop-up ads. The also could not be removed using msconfig, editing the registry, or even deleting their .exes in administrative mode. Ultimately, I had to use Norton Power Erase, tdsskiller.exe, and MalwareBytes anti-malware and anti-rootkit software to put an end to the madness. The settings for IE11, Chrome, Opera, and the LAN settings in general also had to be manually reset after the malware was removed. I'm not certain if the original slow-downs were caused by this malware. I did not even see them until after I downloaded Teamviewer. Confused

Long story short: my Windows 7 system appears to running 100% like it should right now. Bare in mind, I only have 2 USB peripherals attached right now, and I haven't found out why multiple Linux distros also ran at a record slow speed.

TO DO: Need to reflash the motherboard's BIOS so I can use a newer processor.

TO DO: Will check the USB port voltage for any noise or odd voltage events if there are further problems. It's possible the power supply might be under-sized. Evil or Very Mad
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum