So I updated my fx-CG50 to 3.80, and I'm not too impressed.

I had a number of add-ins installed that now cause a system error when run, requiring the calculator to restart. Confused

I'm not sure what the issue is, but if you're happy with how your calculator is set up I'd advise against updating for now. With 3.70 all my add-ins ran with no problems.
Interesting. I was planning on updating soon, so thanks for letting me know!
These are TLB errors btw, whatever that means Confused
It's probably an addin trying to access memory incorrectly because something has moved addresses between OS versions.

Would it be possible to get a list of the addins that work on 3.70 and now crash on 3.80 ?

I guess you can go back to 3.70 the time we investigate what changes between these two versions of the OS.

Well, on my CG50 I had KhiCAS, Graph3DP, BlackJack, Cubefield, and NESizm seemingly running fine on 3.70

For the moment it would be reasonable to assume that no 3rd party add-ins will run without generating an error on 3.80

The specific error looks like this:
System ERROR

That error is generated from doing the following:
Launch 3rd party add-in
Press menu to go back to the menu
Open built-in function or add-in
Press menu to go back to the menu
Launch 3rd party add-in again, and voila, system error

I don't know yet if it's possible to go back to 3.70 Sad
slyVTT was saying here that you can downgrade, via the OS error screen.
Ok do you know how to access the OS error screen?
OK I have solved my problem! Very Happy

I managed to find the OS update program for 3.70 here (this is for Mac):

Make sure the update program is running and ready to go and the calculator is already connected

While holding F2 + 4 + AC/ON, have someone press and release the restart button.
The screen will go blank. Press 9, then press X (multiply). The OS Error screen appears. I then began the update process and it worked!

I'm back to 3.70 and will be staying with that OS.
We are investigating the issue with Lephé.
As written, this is on the second addin launch that we got a crash. Never on the first one.
And this is not happening with all addins. Some are running well.
We are trying to isolate the root cause.
We got official add-ins to crash on a freshly-updated calculator after a full storage memory + add-in reset. This is really looking like an OS bug IMO. If we can reproduce that on more calculators independently I'll write to CASIO to let them know.
Oh wow, 3rd party I can understand but official add-ins?! Not good. Thank you all for the help and updates. Very interesting.
Quick update: we're tracking this on this thread on Planète Casio:

Long story short, this appears to have little to do with the code of the add-in or even the G3A file. Rather, it seems to be a menu bug based mostly on the position of the add-ins.

So far SlyVTT and I have both been able to cause a crash with only official add-ins installed, but with different setups and positions, which is unsatisfying for a proper bug report. Critor gets less bugs than us, the only position where he's had a bug is too far down the list to be reachable with only official add-ins installed, and he also needs a more specific setup.
Interesting. Question; if you have a calculator running 3.80, can you check in the System -> (F4) Version and see what the OS version is compared to the menu version? I checked this when I had 3.80 and noticed that while the OS indeed showed 3.80, Menu showed 3.70. If this has something to do with the bug it might be worth investigating.

I've read up on the thread on the other forum, unfortunately my French, as well as my programming knowledge, is not so great Laughing
It's also 3.70 for me. Not sure what it means, though...

For anyone curious about the thread in French we've mostly been trying to reproduce the bug with official add-ins and copies of official add-ins, and so far the biggest hurdle is that the positions which cause the crash vary from calculator to calculator.
I'm worried about where Casio are heading with their recent works. A faulty os update and a awful new 991-ex replacement (
cg50 wrote:
I'm worried about ...
The quality goes down in general. 30 years old calculators used 100% of its HW, the user interface had real time response. Calculators from this millenium have much powerfull HW, but the response is similar of worse. Old fx7700GB had 8KB RAM and 4228B was available for user. fx cg50 has around 6MB RAM (I am not sure), but only around 64KB is for user.
Take the functionality of cfx9850G and Algebra FX 2.0+, calculators from the end of last millenium. What functionality was added to the newer models? CAS disappeared at all. Long integers? Nope. Number precision and range still the same.
Sad story...
But we can take advantage of the better hardware and do cool things that were impossible on previous models! I'll admit I rarely use the built-in math apps these days... but I'm having a blast with all the programming nonetheless. I think it's excellent in that regard Smile
Lephe wrote:
But we can take advantage of the better hardware...

Yes, you are absolutely right. But still I think there is a lot of room for improvement in the CASIO FW. The majority of people do not buy calculators for programming plugins, but for using that device as a calculator Smile
But yes, still much better than another company, which actively prohibits using their products differently than designed.
All, FYI Casio is now aware of the bug.
We got in touch with them and explained how to reproduce it on their own calculators.
Now we just need to cross of fingers for them to find a solution and to provide an update of the firmware.
Let see how it moves forward.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 2
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum