darkwater4213 wrote:
Hm. Why not, may I ask? I would certainly appreciate it if you would give a reason instead of simply a blunt, unqualified, unjustified "No," and instead showed your line of reasoning which assumably led to this conclusion.

Because it's a dumb request?
Could you please explain why it is a dumb request? I, for one, think that it may be a but hard to implement, butt still reasonable. Admittedly, I'm biased, but still.
darkwater4213 wrote:
Could you please explain why it is a dumb request? I, for one, think that it may be a but hard to implement, butt still reasonable. Admittedly, I'm biased, but still.

Then implement it?
I have no experience in C and don't even know how asm works. Are you completely sure that I would be the best candidate for working on it?

Why should I implement something I think is dumb?

I didn't say you personally should implement it. I am merely suggesting that I should not be the one to implement it.

(This kind of goes for both the tags idea and the invisible idea)
Epsilon5 sounds like he’s willing to do it, anyway.
Hi MateoConLechuga, I am using a Toshiba 32 gb stick, I also have installed the newest version of Cesium and the files you mentioned in the post before. Though it keeps saying insert Fat32 formatted drive
First, I would suggest making sure there is a FAT32 partition on the drive; that's pretty important. FAT, exFAT, and FAT32 are not the same. I would also suggest creating a separate partition for Cesium, so you can leave the rest of the drive as-is (as NTFS or whatever). Another reason is that it might be possible that Cesium can't cope with the 32 GiB, but I don't know because I'm no personally familiar with the inner workings of Cesium. Hope this helps!
Yeah there is a fat 32 partition, I have also tried other fat 32 drives with less giBs, like 4, 8 and 2 but still had no success
SGTMM wrote:
Yeah there is a fat 32 partition, I have also tried other fat 32 drives with less giBs, like 4, 8 and 2 but still had no success

Send a link to where I can purchase these flash drives please Smile
Here is the link. However you might have problems as this is Italian Amazon so I don’t know if you will be able to receive it.

Thanks, shipping placed through the US and delivery looks like early June lol Smile
I updated Cesium and all the C libraries, but Cesium still says that I need a library called USBDRVCE.
Clarifier: Before, there was a Cesium message that I didn't have the requisite libraries, but now it is a screen that looks like other OS messages that you are missing libraries that I've seen from other programs.
Also, just wondering, what is a FAT32 partition? I have checked, and the drive I'm using is FAT32-formatted.

EDIT: I forgot to say that the calculator reboots (but doesn't ram reset) every time you try the drive.
"FAT32 partition" can refer to a partition marked with one of the FAT32 types inside the partition table of your drive (say, 0xC for a MS-DOS partition table); and the data in the area of the mass storage which corresponds to the partition should be FAT32-formatted, indeed.
Okay, sorry, but I don't understand all of what you mean. What is a partition table? I thought it just had a format which was the file system.
On any type of storage system aimed at storing filesystems, there's got to be something which declares how large it is, and more relevant to the current discussion, how large the filesystems stored in this piece of storage system are.
That's the purpose of the partition table: declaring bounds and types for partitions stored in the storage space. Partitions need not fill the entire storage space: you can create just a single filesystem of several dozen MBs (the lower bound depends on the filesystem type, obviously) even on 20+TB HDDs.

It is technically possible to store a filesystem on a raw block device without creating a partition table first, but it's not recommended at all, as some programs do expect proper partition tables.
So how could you add/view partition tables? I understand that for the whole flash drive, but not necessarily for only parts of it. When I click on "View details" for the flash drive (I'm on Mac), it just tells me how it is formatted.
Maybe `fdisk` exists and works on MacOS ? There must also be a boatload of GUI tools, with varying level of functionality and ease of use. [EDIT: on the chat, LogicalJoe indicates "fdisk does exist." & "I tend to just use Disk Utility to partition disks"]
On Linux, I use `fdisk`, or of course GUI tools such as GParted, but one doesn't have this luxury in headless or scripted environments Smile I'd do the same on the BSDs.
On Windows, there's a native tool in the management console (mmc) to deal with storage, but it has very limited functionality.

Sorry, it's been over a decade since I administered a Mac running MacOS, so the Internet shall be a much better resource for finding information than I can be Smile
It was a work computer, and I only tried to use it under MacOS (X) for a week, before simply installing Linux to increase my productivity greatly: I was supposed to use that computer to perform real work, not spend significant time compiling programs from MacPorts and fix others not on MacPorts so that they worked on that OS.
Thankyou! I forgot about Disk Utility.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
» Goto page Previous  1, 2, 3 ... , 22, 23, 24  Next
» View previous topic :: View next topic  
Page 23 of 24
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum