So today I tried to create an account for TI-Planet, but it doesn't really like me it seems:

I tried re-entering my email, reloading the page, cookies, etc. but it still does not work.
Is there a way to fix this, and has anyone else had the same problem?


(Note: If you need my email, just tell me and I'll PM it to you)

Please share the email which triggers the error with us.

MP, or mailto info(at)

Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum