Does anybody like Minecraft?
I do
 58%  [ 7 ]
I kinda do
 8%  [ 1 ]
I do not
 33%  [ 4 ]
Total Votes : 12

I cannot figure out how to install mods into Minecraft! So far, it seems to require "jailbreaking" and is a pain in the head just to think about. But I so wish I could. I use software called "WinAce"(from Windows 95), and followed all directions for the ModLoader, ModLoaderMP, and mod itself. What I got was, in MC 1.8.1, a black screen, and in MC 1.0.0, a (very pretty - good job Notch!Smile ) a crash screen. I did delete the META-INF folder. PLEASE HELP, someone knowledgable!
You just need to download something like MC Patcher or ModLoader.

If you need help with the steps just post where you get lost or stuck.
The two mod loaders could be conflicting, try only installing one at a time. Also, why aren't you using 7-Zip? Try installing a different, simpler mod to figure out how to do it (TooManyItems is pretty good for this), and install the mod you want later.

Edit: Autocorrect sucks
What sort of mods are you trying to install? I'm assuming that you have a legitimate copy of Minecraft; if so, you should join us on the PvP/Build server when we get it up and running with MC 1.0.0 in a week or two.
What Kerm said. What mod are you trying to use? Are you sure you are using the right files? Etc
I am trying to install the ChristmasCraft mod, and I have no idea how to install it. It didn't come with a readme. Has anyone else installed the ChristmasCraft Mod?

I just figured WinAce should work as well as 7-zip, which I would prefer not to download unless neccessary because we have a 3G network w/ limited data.
I would think that you do thing

1. Install modloader
2. Delete meta-inf
3. Install chrismascraft mod, be sure to move/replace correct files/folders into the right place of the minecraft.jar...
How in the world do I install modloader? Also, how do I know where to put the ChristmasCraft Mod? (It is a .jar file + a "resource" folder.)
You just download it, and run it.
It is all .class files! How do I run that???
Mods loaded: 1
ModLoader 1.0.0

Minecraft has crashed!

Minecraft has stopped running because it encountered a problem.

If you wish to report this, please copy this entire text and email it to
Please include a description of what you did when the error occured.

--- BEGIN ERROR REPORT 141ccf11 --------
Generated 12/17/11 9:46 PM

Minecraft: Minecraft 1.0.0
OS: Windows Vista (x86) version 6.0
Java: 1.6.0_26, Sun Microsystems Inc.
VM: Java HotSpot(TM) Client VM (mixed mode), Sun Microsystems Inc.
LWJGL: 2.4.2
OpenGL: GeForce 6150SE nForce 430/PCI/SSE2/3DNOW! version 2.1.2, NVIDIA Corporation invalid entry size (expected 2373386248 but got 4592 bytes)
at ModLoader.readFromClassPath(
at ModLoader.init(
at ModLoader.AddAllRenderers(
at wb.<init>(
at wb.<clinit>(
at net.minecraft.client.Minecraft.a(SourceFile:265)
--- END ERROR REPORT 69eeeecc ----------
Download ChristmasCraft 1.0 for Client 1.0.0 here: MediaFire
1) Risugami's ModLoader and ModLoaderMp are required for this mod! Install and run them once first!
2) Unzip the ChristmasCraft download, and you will find ChristmasCraft_client.jar file and a "resources" folder
3) Copy ChristmasCraft_client.jar into your ".minecraft/mods/" directory
4) Copy the "resources" folder into your ".minecraft/" directory, merging it with the existing "resources" folder
5) Spread some Christmas cheer!
@qazz42: I did all that. What I got was the above, NOT Christmas cheer!
Did you install modloaderMP too? I think that is needed. Did you move the Christmas_Client.jar into the "minecraft/mods" and not "minecraft/mod"?

did you delete the meta-inf from the minecraft.jar?
Oh! I Downloaded 7-Zip, and it solved all my problems! Seriously! WinAce of Windows 95 fame did not work. So. Download 7-zip if you have any trouble! Thank you all for the help, especially Souvik1997! It worked!
Wait.. what? You were using WinAce? Psh, no wonder it was not working XD

(and also, I think pretty much everyone here using 7zip, as they are cool like that Very Happy)
Ok, so now how do I install the Walled Cities Mod? It is for 1.8.1... I have 1.8.1, if it requires it. I tried to install it, but it gave me a black screen.
comicIDIOT wrote:
You just need to download something like MC Patcher or ModLoader.

I can't figure out how to download MCPatcher from that link.
Right above the section known bugs are a couple of download links.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 3
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum