I tried 3 different computers, I uninstalled and reinstalled the program, I even factory reset my computer. I firmly pressed the charger into the calculator. I just cannot get it to connect. I also tried using the original TI Connect.
factory resetting was probably not necessary, other that that, it seems that you have tried everything, or at least most of the things we would suggest. Also, was this the first time you tried connecting your ti 84 to your computer? A wild guess of mine would be that there could be a program running, even though that is kind of unlikely...
Yes, it was the first time. It's my first Ti-84 Plus. I boot up the computer and only click Ti-Connect CE which I think means it is the only program running.
Sorry, this must be a TI-84 Plus C Silver Edition or a TI-84 Plus CE, since you mentioned charging, correct? I was definitely going to suggest the problem with plugging in the calculator more firmly. Did you try a different USB cable? If you look at your Device Manager (assuming this is Windows) does it appear that the device is listed at all? Listening for the "device connected" sound when you plug it in would be a decent indication of that.
TI-Connect CE won't recognize the calculator if TI-Connect is installed. Make sure to uninstall both and reinstall only the CE version.
Really? I have both installed and it works? Just install Ti Connect first, then Ti Connect CE.
No, it is a normal Ti-84 Plus (not silver edition). I can't charge this one, right? I uninstalled Ti Connect and Ti Connect CE and then only installed Ti Connect CE. It didn't work. Also, when I plug the calculator in the computer does not make a noise and if I look in the device manager I don't see a Ti-84 Plus. I didn't use a different USB cable because I only bought one off of eBay. Lastly, when I plug it in the only thing that really happens is the calculator screen freezes and I cannot press a button on it.
Try just using Ti Connect. CE *should* work iirc, but try just using Ti Connect, not the CE version.
I uninstalled CE and installed the normal Ti Connect. I plugged the calculator in and went to device explorer. It searched for a little and then told me it could not establish a valid connection.
JD21 wrote:
Lastly, when I plug it in the only thing that really happens is the calculator screen freezes and I cannot press a button on it.
Now this is interesting information. That shouldn't happen. The calculator takes a regular mini-USB cable; surely you have another one around you can try? Also, I doubt it's the problem, but occasionally a different USB port on the computer has done the trick for some.
Try following the steps in these videos:

Yeah I know it seemed like a weird problem but no I don't have another cord to try since I only bought one from eBay. I tried all the USB ports already.

I'll try these videos now.

Edit: I tried the tips in the video except for trying a new charger. They didn't work.
Update: The new cord came today and it worked. Thanks for help.
Register to Join the Conversation
Have your own thoughts to add to this or any other topic? Want to ask a question, offer a suggestion, share your own programs and projects, upload a file to the file archives, get help with calculator and computer programming, or simply chat with like-minded coders and tech and calculator enthusiasts via the site-wide AJAX SAX widget? Registration for a free Cemetech account only takes a minute.

» Go to Registration page
Page 1 of 1
» All times are UTC - 5 Hours
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum